[gelöst] Installationsprobleme

josc22
Beiträge: 10
Registriert: Sa 23. Nov 2019, 16:55

Installationsprobleme

Beitrag von josc22 » So 24. Nov 2019, 12:20

Hallo liebe Nutzer,

ich soll für einen lokalen Verein ein Laptop mit der Meyton ShootMaster II Software installieren. Der Laptop soll das einzige Gerät für den Verein mit der Software sein. Ich habe mir das Script bereits über den Onlinezugang bezogen und den Laptop mit openSuse versorgt. Jetzt habe ich das Problem, dass mir wahrscheinlich das Verständnis fehlt, wie die Software arbeitet.

Ich soll bei der Installation die IP Konfiguration meiner eth0 Schnittstelle anpassen, wieso ist das von nöten? Nach sämtlichen Varianten beendet das Script mit Can not connect to X server? Wo versucht sich die Software hinzuverbinden? Ich will erstmal nur die Software installieren und mehr nicht. Laut der Doku soll man dem Server die Host .200 und den Clients ab .201 vergeben, auch das klappt nicht. Auch die Eingabe der Netzwerkkonfiguration in meinem Heimnetzwerk klappt nicht, falls sich die Software über das Internet noch Zeugs zieht? Komisch finde ich auch, dass die Software versucht 32bit Libs nachzuziehen die dann abgebrochen werden oder ein MySQL benötigt wird? Hilfe.

Die Frage die sich mir jetzt allerdings stellt, brauche ich eine weitere Komponente für die Installation? Wie mache ich nun weiter und wo liegt das Problem?

Grüße,
Jonas

Benutzeravatar
[MEYTON CM] Mario
Beiträge: 813
Registriert: Fr 6. Mai 2016, 15:11
Verein/Verband: SV "Edelweiss"-Bühl e.V. / BSSB

Re: Installationsprobleme

Beitrag von [MEYTON CM] Mario » So 24. Nov 2019, 18:20

Hallo Jonas,

ich stelle mir gerade die Frage ob dieser Verein Produkte von der Fa. Meyton bezogen hat?
Ist diese Software gekauft worden?
Oder hat dieser Verein "nur" die Hardware OHNE Meyton-Software gekauft > Ich denke das wäre dann hie nicht zulässig (rechtlich)

Wie heißt denn der Verein?
Wie alt ist die Anlage?
Wieviele Stände sind es denn?
Läuft die Anlage mit CPC oder ESTA5?
Gibt es ein DC?
usw. ...

Wie Du schon siehst, Fragen über Fragen.


Schöne Grüße
Mario

[MEYTON] RG
Beiträge: 272
Registriert: Mi 9. Mär 2016, 16:14

Re: Installationsprobleme

Beitrag von [MEYTON] RG » Mo 25. Nov 2019, 10:47

Wenn ihr die Software von Meyton bezogen habt, bekommt ihr Zugang zum Download-Bereich auf unserer Homepage. Dort findest ihr die aktuelle Version 4.9.6a der ShootMaster-Software und weiter unten noch Anleitungen zur Installation von openSUSE und zur Installation der ShootMaster-Software. Damit sollte die Installation eigentlich kein Probllem sein. Einfach genau nach den Anleitungen vorgehen.

josc22
Beiträge: 10
Registriert: Sa 23. Nov 2019, 16:55

Re: Installationsprobleme

Beitrag von josc22 » Di 26. Nov 2019, 07:37

Hallo,

@Mario
die Software ist ganz normal vom Verein über Meyton beschafft worden und wir haben einen Nutzeraccount welcher den Download der Software zur Verfügung stellt. Meine Frage bezieht sich auf die Installation.

@RG
Muss der Laptop dafür mit dem Stand verbunden sein oder lässt sich die Software (Kontrollzentrum) auch ohne die direkte Verbindung installieren? Anscheinend versucht ja das Script bei der Installation durch die Angabe eines definierten Subnetzbereiches eine Verbindung zu den "Clients" herzustellen? Muss für die Installation Software bereits installiert sein, z.B. Apache? ich habe mich an die Doku gehalten, aber wie gesagt, habe halt Fehlermeldungen.

Könnte es ein Problem sein, wenn ich die Minimal Version von openSuse installiert habe?

Woher kommt meine Fehlermeldung "Can not connect to X server"?

ich bin lediglich beauftragt worden diese Software auf dem Laptop bereitszustellen und selbst nicht tätig im Schützensport, daher mangelt es mir wahrscheinlich an dem Hintergrund der Software.

Grüße,
Jonas

trefferass
Beiträge: 25
Registriert: Di 17. Sep 2019, 11:40

Re: Installationsprobleme

Beitrag von trefferass » Di 26. Nov 2019, 08:46

Hallo,
ich nehme an, du möchtest die SM II auf das Laptop installieren, um danach den Meytonstand zu administrieren, Wettkämpfe durchzuführen und die Ergebnisse hinterher auszuwerten. Dann wird das Laptop also zum Master. Dazu installierst du Suse 15 zuerst. Das Image kannst du im Downloadbereich von Meyton beziehen. Die Installation geht natürlich auch zu Hause ohne Meytonstand. Vorgehen:
SUSE Linux 15 neu installieren:
Du solltest das Laptop mit einem Switch verbinden, damit die Netztwerkkarte korrekt installiert werden kann.
- InstallationsCD mit Image SUSE15 ins CD-Laufwerk oder USB Stick und davon booten, je nachdem ..
- Booten
- installieren auswählen
- Systemsprache „Deutsch“ auswählen
- Netzwerkeinstellungen „Bearbeiten“
- bei Workstation Installation: statische IP: 192.168.10.200; Subnet: 255.255.0.0 (weil Master)
- weiter
- Benutzerschnittstelle: Desktop mit KDE
- geführtes Setup
- Löschen, falls nicht benötigt bei existierenden Partitionen
- root Partition „ext4“
- Haken weg bei “Separate Home Partition“
- andere vorbelegte Haken so lassen
- weiter
- Region „ Europa“ und Zeitzone „Deutschland“
- weiter
- Benutzereinstellungen überspringen
- weiter
- Paswort für Root eingeben **** (sollte bekannt sein)
- Abfrage mit „ja“ bestätigen
- dann „Installieren“ ( ca. 45 Minuten)
Wenn fertig, CD raus und System neu starten (natürlich jetzt von HDD)
Wenn alles fertig ist, solltet du den Stand benutzen können. Bei StandPC's , also keine Tablets, zuerst das Laptop mit der SMII komplett hochfahren und erst danach die StandPC's einschalten.
Gruß Rudolf

josc22
Beiträge: 10
Registriert: Sa 23. Nov 2019, 16:55

Re: Installationsprobleme

Beitrag von josc22 » Mi 27. Nov 2019, 22:30

Hallo,
ich nehme an, du möchtest die SM II auf das Laptop installieren, um danach den Meytonstand zu administrieren, Wettkämpfe durchzuführen und die Ergebnisse hinterher auszuwerten. Dann wird das Laptop also zum Master.
Ja, ganz genau.

So habe ich den Laptop nun auch zum zweiten Mal neu aufgesetzt. Allerdings mit der vollständigen openSuse Installation direkt von der Meyton Seite. Leider bekomme ich immer noch den selben Fehler:
SetEth0IPAndNetmask 192.168.10.100/16
setup: cannot connect to X server
... und die Installation wird abgebrochen. Nochmal die Frage bzgl Apache oder sonstigem? Muss irgend was noch installiert oder angepasst werden?
Ich schicke mal den kompletten Output hier rein... das sieht allgemein komisch aus?
Verifying archive integrity...100%
Uncompressing MEYTON_INSTALL 100%
Basic.sh 4.0.7_Next
LinuxArch = 64
MyVersion = 151
Neuinstallation erkannt. Merker gesetzt
Bilde neues NextRPMs
--1 --2 --3
SMAutoLibs: Daten entpacken
INSTALL : ----> 32Bit NOW for 151
error: Failed dependencies:
libgcc_s1-32bit conflicts with libgcc_s1-32bit-8.2.1+r264010-lp151.1.33.x86_64
libgcc_s1-32bit conflicts with (installed) libgcc_s1-32bit-8.2.1+r264010-lp151.$
libstdc++6-32bit conflicts with libstdc++6-32bit-8.2.1+r264010-lp151.1.33.x86_64
libstdc++6-32bit conflicts with (installed) libstdc++6-32bit-8.2.1+r264010-lp15$
libstdc++6-locale conflicts with libstdc++6-locale-8.2.1+r264010-lp151.1.33.x86$
libstdc++6-locale conflicts with (installed) libstdc++6-locale-8.2.1+r264010-lp$
INSTALL : ----> Fehler beim Installieren der 32bit Libs!
InitBaseServices: Init base services via systemctl...
Failed to stop SuSEfirewall2.service: Unit SuSEfirewall2.service not loaded.
Failed to disable unit: Unit file SuSEfirewall2.service does not exist.
Failed to enable unit: Refusing to operate on linked unit file mysql.service
^[[3J^[[H^[[2JSetEth0IPAndNetmask 192.168.10.200/16
setup: cannot connect to X server
Grüße,
Jonas

[MEYTON] RG
Beiträge: 272
Registriert: Mi 9. Mär 2016, 16:14

Re: Installationsprobleme

Beitrag von [MEYTON] RG » Do 28. Nov 2019, 10:05

"cannot connect to X server" bedeutet, dass es Probleme mit der grafischen Oberfläche gibt. Das Installationsprogramm ist ein Programm mit grafischer Oberfläche und zur Darstellung der Fester wird der X Server benötigt. Vermutlich gibt es bei deinem Laptop Probleme mit dem Grafiktreiber. Startet openSUSE in die grafische Oberfläche?

josc22
Beiträge: 10
Registriert: Sa 23. Nov 2019, 16:55

Re: Installationsprobleme

Beitrag von josc22 » Do 28. Nov 2019, 11:19

Ja openSuse start in die GUI. Was muss denn genau nachgezogen werden? Wie gehe ich nun weiter vorran?
Ich kann nachschauen was der Grafiktreiber ist und ob dieser unterstützt wird....

Stumic
Beiträge: 4
Registriert: Fr 16. Nov 2018, 12:49
Verein/Verband: St.Hub. Steinshardt

Re: Installationsprobleme

Beitrag von Stumic » Fr 29. Nov 2019, 21:59

Liegt es vielleicht an der falschen IP ?

"SetEth0IPAndNetmask 192.168.10.100/16
setup: cannot connect to X server"

Wenn er Eth0 auf 192.168.10.100 anstatt auf 200 setzt ? Fragt das Installationsprogramm vielleicht IP 200 ab ? :?:

josc22
Beiträge: 10
Registriert: Sa 23. Nov 2019, 16:55

Re: Installationsprobleme

Beitrag von josc22 » Fr 29. Nov 2019, 22:22

Naja was heißt falsche IP-Adresse? Es ist vollkommen egal welche IPv4-Konfiguration ich verwende, der Fehler bleibt der selbe.
Da mir ja keiner so wirklich erklären kann für was die IPv4-Konfiguration für die Installation von nöten sei, weiß ich es auch nicht. Normalerweise benötige ich die IPv4-Konfiguration zum Verbinden des Servers zu den Clients an den Ständen, aber doch nicht für die Installation!? Nach Installationsanleitung ist es ja ausreichend diese einfach auf dem Standardwert zu belassen!?

Mein nächster Versuch wird sein, eine ältere Version des Programmes zum Laufen zu bekommen.... Auch wenn ich bezweifel das dies was zu bringen vermag. Da mein OS ja in der GUI startet kann es schon mal kein Problem mit irgendwelchen Treibern etc zu geben. Ich habe keine Ahnung was das Problem bzgl der GUI für das Script ist.

Ich muss ehrlich sagen, dass ich enttäuscht bin seitens Meyton hinsichtlich der Hilfe. Es gab noch keine gescheite Lösungsvorschläge, geschweige denn Ansätze. Anscheinend sind die Kunden auf sich alleine gestellt, wenn die Installation von der Anleitung abweicht und es zu Problemen kommt. Für einen 0815 Anwender gar nicht umsetzbar ohne Kenntnisse hinsichtlich Linux!

Antworten